Home   Help Search Groups Login Register  
You are not logged in. To get the full experience of these forums, we recommend you log in or register
Plusnet Usergroup » All Users - The Open Forum » The PUG Place » Gateway checker
Pages: [1]
  Print  
Author Topic: Gateway checker  (Read 3367 times)
jelv1

Posts: 2130

« on: September 26, 2014, 02:12:45 pm »

Please could you explain the difference between:

http://usertools.plus.net/@gateway - this works

http://usertools.plus.net/@gateway/?debug-ip - says "Sorry, records show your IP address is not from the Plusnet brand and as such, we cannot detect your gateway."

http://usertools.plus.net/@gateway_custom - looks the same as the first

http://usertools.plus.net/@gateway_custom/?debug-ip - displays an array and comes up with the same answer.


jelv
MauriceB
Administrator

Posts: 4356

« Reply #1 on: September 26, 2014, 02:38:58 pm »

Thanks for question John.  I do recall some of the detail harks back to the issue with the new ex US IP addresses and some debugging, but Spraxyt is the man with the coding pen, so I'll defer to him for a fuller answer.

May be a slight delay as the new Server tripped out a little while back, plus a few other residual problems post the migration to be resolved.

Both Usertools and Usergroup live on the new Server now police

Maurice
jelv1

Posts: 2130

« Reply #2 on: September 26, 2014, 04:04:37 pm »

Just an idea: on the main version http://usertools.plus.net/@gateway could you put a Debug button to run it with the /?debug-ip? Might be useful when people report problems.

jelv
spraxyt
Usergroup Member

Posts: 3003

« Reply #3 on: September 26, 2014, 07:23:08 pm »

Please could you explain the difference between:

http://usertools.plus.net/@gateway - this works

http://usertools.plus.net/@gateway/?debug-ip - says "Sorry, records show your IP address is not from the Plusnet brand and as such, we cannot detect your gateway."

That's what I'd expect you to have got because it wasn't doing what you expect. I've made a small alteration so that option is ignored.

Providing a debug button could be useful. I'll look into adding this. smiley

David
Pages: [1]
  Print  
 
Jump to: