Home   Help Search Groups Login Register  
You are not logged in. To get the full experience of these forums, we recommend you log in or register
Plusnet Usergroup » All Users - The Open Forum » Plusnet Customer Service Issues » Speed still slow despite upping monthly spend
Pages: [1]
  Print  
Author Topic: Speed still slow despite upping monthly spend  (Read 2065 times)
Heather1

Posts: 2

« on: September 06, 2013, 04:31:14 pm »

Hi all,
I went over my usage allowance (as often happens) and my speed was cut drastically. This appears to be something new, never happened before. I upped my permitted monthly spend by 1GB as advised (I have Broadband my way, an old product) but some hours later it's still unacceptably slow.
Does anyone know how long this will last before the change takes effect?
Tried phoning the 0800 number but waits were 15mins+ and the website for some reason won't allow me to 'raise a ticket'.
jelv1

Posts: 2130

« Reply #1 on: September 06, 2013, 04:38:50 pm »

I don't know how often the Plusnet staff look at these forums as they are very little used these days so you'd probably do better to post on the Community forums: http://community.plus.net/forum/index.php

You could try a disconnect/reconnect to see if that resets things.

Have you looked at changing to one of the new accounts. For most people they will save money.

jelv
Heather1

Posts: 2

« Reply #2 on: September 06, 2013, 04:47:08 pm »

Thanks for the advice Jelv. The new products look better but I may be changing ISPs (to a community broadband scheme) within a few months. I'll try the other ideas.
Pages: [1]
  Print  
 
Jump to: